User Tools

Site Tools


en:infra-convert:user:cadexp:nx_12
infra CONVERT 2019 user manual > Exporting drawings from the CAD system > Siemens PLM

NX 12


This manual describes how to export drawing files in DWG, DXF, IGES and PDF formats (→Drawing data format) from the NX 12 CAD system. The recommended settings ensure that the drawing file can be read by infra CONVERT 2019 in the best possible way.

The manual does not give a complete description of drawings export Please also take note of the CAD system provider's documentation.

The instructions can be applied to the following program versions analogously:

  • NX 11

Content

 • DWG export
 • DXF export
 • IGES export
 • PDF export
 • Troubleshooting


DWG export

Step Action/result
1 Customise drawing view In “Drafting” mode, under File > Preferences click on Drafting. This opens the “Drafting Preferences” menu.

Select the 'View’ > ‘Workflow’ page. Deactivate the display of the edge of the view :


Then close the menu by clicking on OK.
2 Customise export settings Under File > Export, click on AutoCAD DXF/DWG… This opens the “AutoCAD DXF/DWG Export Wizard“ menu. Select the settings shown in the following illustration. The essential settings are enclosed in red.

“Input and output” page:


“Data to Export' page:


“Options” page:
Important Users of infra - CONVERT (Version 11 or earlier) should please select “2004” under “DXF/DWG Version”.
3 Export drawing Close the export using Finish.


DXF export

Step Action/result
1 Customise drawing view In “Drafting” mode, under File > Preferences click on Drafting. This opens the “Drafting Preferences” menu.

Select the 'View’ > ‘Workflow’ page. Deactivate the display of the edge of the view :


Then close the menu by clicking on OK.
2 Customise export settings Under File > Export, click on AutoCAD DXF/DWG… This opens the “AutoCAD DXF/DWG Export Wizard” menu. Select the settings shown in the following illustration. The essential settings are enclosed in red.

“Input and output” page:


“Data to Export' page:


“Options” page:
Important Users of infra - CONVERT (Version 11 or earlier) should please select “2004” under “DXF/DWG Version”.
3 Export drawing Close the export using Finish.


IGES export


PDF export


Troubleshooting

Written characters not correctly displayed in DWG/DXF drawings

Description of error

Several characters, in particular graphic symbols, are not correctly displayed in infra CONVERT 2019 and cannot be read when stamping.

Examples:


Correcting error

Usually the relevant fonts have not been installed on the computer that is running infra CONVERT 2019. For licensing reasons we are not able to include Siemens-specific →fonts in our delivery. The fonts written during export are executed in the export settings in NX; see File > Export > AutoCAD DXF/DWG… > Fonts.


Scroll backwards
Export drawing from the CAD system > Siemens PLM > NX 10

Scroll forwards
Export drawing from the CAD system > Siemens PLM > Solid Edge ST2

en/infra-convert/user/cadexp/nx_12.txt · Last modified: 2019/07/01 13:30 by me