Benutzer-Werkzeuge

Webseiten-Werkzeuge


de:infra-convert:dev:uiaccess

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen gezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
de:infra-convert:dev:uiaccess [2020/03/31 13:29]
me
de:infra-convert:dev:uiaccess [2020/09/21 13:29] (aktuell)
me
Zeile 8: Zeile 8:
  
 <WRAP group> <WRAP group>
-<WRAP column ​75%>+<WRAP column ​90%>
 ====== Parameterdatei "​UiAccess"​ ====== ====== Parameterdatei "​UiAccess"​ ======
  
 ---- ----
 </​WRAP>​ </​WRAP>​
-<WRAP column ​20%> +<WRAP column ​5%> 
-> **Verfügbar ab**\\ Programmversion 1.1.5+{{ :​de:​infra-convert:​dev:​icon_dev_uiaccess_2.png?​nolink&​50|}}
 </​WRAP>​ </​WRAP>​
 </​WRAP>​ </​WRAP>​
 +
 +> **Verfügbar ab** Programmversion 1.1.5
  
 In der Parameterdatei "​UiAccess.json"​ ist festgelegt, welche Steuerelemente in der Benutzeroberfläche eingeblendet,​ ausgeblendet oder gesperrt sind. In der Parameterdatei "​UiAccess.json"​ ist festgelegt, welche Steuerelemente in der Benutzeroberfläche eingeblendet,​ ausgeblendet oder gesperrt sind.
Zeile 31: Zeile 33:
  
 Soll beim Programmstart eine andere Parameterdatei geladen werden, kann dies in der Startparameterdatei (siehe Konfiguration und Import > [[de:​infra-convert:​dev:​parameter#​Parameterdatei zum Ein-/​Ausblenden/​Sperren von Steuerelementen]]) vorgegeben werden. Soll beim Programmstart eine andere Parameterdatei geladen werden, kann dies in der Startparameterdatei (siehe Konfiguration und Import > [[de:​infra-convert:​dev:​parameter#​Parameterdatei zum Ein-/​Ausblenden/​Sperren von Steuerelementen]]) vorgegeben werden.
 +
 +Eine vollständige "​UiAccess.json"​ mit Standardeinstellungen können Sie im Administratormodus aus der Benutzeroberfläche von #​@IC_HTML@# ​ heraus exportieren. Siehe hierzu: Benutzerhandbuch > Einstellungen > Einstellungen > Administration > [[de:​infra-convert:​user:​config:​export#​gruppe_„konfigurationsdateien_exportieren|Gruppe „Konfigurationsdateien exportieren“]]. (Verfügbar ab Programmversion 2.2.3)
  
 <WRAP noprint> <WRAP noprint>
Zeile 64: Zeile 68:
 |< 100% 23% 12% 65% >| |< 100% 23% 12% 65% >|
 ^  Parameter ​ ^  Typ  ^  Wert/​Inhalt ​ ^ ^  Parameter ​ ^  Typ  ^  Wert/​Inhalt ​ ^
-^ Affected​Element​Name | String | __"​Datei"​ (Menüleiste) und Werkzeugleiste__\\ **NewProject** "​Datei > Neues Projekt";​ "Neues Projekt“\\ **OpenProject** "​Datei > Projekt öffnen“; "​Projekt öffnen“\\ **SaveProject** "​Datei > Projekt speichern";​ "​Projekt speichern“\\ **SaveProjectAs** "​Datei > Projekt speichern unter“\\ **CloseProject** "​Datei > Projekt schließen“\\ **CloseApplication** "​Datei > Beenden“\\ \\ __Werkzeugleiste__\\ **StampTool** "​Stempel-Werkzeug“\\ **TagTool** "​Kennzeichnen-Werkzeug“\\ **GridTool** "​Feldeinteilung-definieren-Werkzeug“\\ \\ __Werkzeugleiste (nur Zeichnungsvergleich)__\\ **TransferTool** "​Merkmale übertragen“\\ \\ __"​Bearbeiten"​ (Menüleiste)__\\ **ProgramSettingGeneral** "​Einstellungen > Allgemein“\\ **ProgramSettingCharacteristics** \\ "​Einstellungen > Merkmale“\\ **ProgramSettingStamp** "​Einstellungen > Stempel“\\ **ProgramSettingImport** "​Einstellungen > Import“\\ **ProgramSettingExport** "​Einstellungen > Export“\\ **ProjectSettingsTolerance** "​Projekteinstellungen > Toleranztabellen“\\ **ProjectSettingsTags** "​Projekteinstellungen > Kennzeichnungen“\\ **ProjectSettingsCategories** "​Projekteinstellungen > Kategorien“\\ **ProjectSettingsTemplates** "​Projekteinstellungen > Stempelvorlagen“\\ **LicenseDialog** "​Hilfe > Lizenz anzeigen"​ (ab Programmversion 1.5.3.0)\\ **LicenseDialogAddLicense** "​Hilfe > Lizenz anzeigen > Lizenz hinzufügen"​ (ab Programmversion 1.5.3.0)\\ **LicenseDialogLicenseServerSetting** "​Hilfe > Lizenz anzeigen > Lizenzserver"​ (ab Programmversion 1.5.3.0)\\ **LicenseDialogRequestLicense** "​Hilfe > Lizenz anzeigen > Lizenz anfordern"​ (ab Programmversion 1.5.3.0)\\ \\ __Fenster "​Projektübersicht"​__\\ **ProjectEdit** "​Projekt > Projekt bearbeiten“\\ **ProjectAddDocument** "​Prüfplan > Zeichnungsblatt hinzufügen“\\ **ProjectAddInspPlan** "​Prüfplan hinzufügen“\\ **ProjectEditInspPlan** "​Prüfplan > Prüfplan bearbeiten“\\ **ProjectDeleteInspPlan** "​Prüfplan > Prüfplan löschen“\\ **ProjectExportMenu** "​Prüfplan > Exportieren als“\\ **ProjectExportJson** "​Prüfplan > Exportieren ​als Json“\\ **ProjectExportAscii** "​Prüfplan > Exportieren ​als > "ASCII-Transformat“\\ **ProjectExportDocument** "​Prüfplan > Exportieren als > Zeichnungsgrafik“\\ **ProjectExportStamps** "​Prüfplan > Exportieren als > Stempelgrafiken“ (verwendet ab Programmversion 1.2.0.29)\\ <​del>​**ProcejectExportStamps**</​del>​ "​Prüfplan > Exportieren als > Stempelgrafiken“ (verwendet bis Programmversion 1.2.0.28)\\ **ProjectExportExcel** "​Prüfplan > Exportieren ​als Excel“\\ **ProjectExportCsv** "​Prüfplan > Exportieren ​als CSV“\\ **ProjectCloseDocument** "​Prüfplan > Zeichnungsblatt löschen“ (verwendet ab Programmversion 1.2.0.29)\\ <​del>​**ProjectCloseDokument**</​del>​ "​Prüfplan > Zeichnungsblatt löschen“ (verwendet bis Programmversion 1.2.0.28)\\ **DocumentVersionOpen** "​Prüfplan > Zeichnungsblatt > Zeichnungsblatt ​öffnen“\\ **DocumentVersionRemove** "​Prüfplan > Zeichnungsblatt > Zeichnungsblatt entfernen“\\ **DocumentVersionExportPdf** "​Prüfplan > Zeichnungsblatt > Als PDF exportieren“\\ **DocumentVersionExportSvg** "​Prüfplan > Zeichnungsblatt > Als SVG exportieren“ (verfügbar ab Programmversion 1.2.0.31)\\ **CompareDocument** "​Prüfplan > Zeichnungsblatt > Zeichnungsblatt vergleichen“\\ \\ __Fenster "​Merkmalübersicht"​ und "​Zeichnungsfenster"​__\\ **CharacteristicContextMenu** "​Kontextmenü“\\ **DocumentSplitCadBlock** "​Kontextmenü > Zerlegen"​ (verfügbar ab Programmversion 1.2.0.31)\\ **DeleteStampKey** Stempel bzw. Merkmal löschen mit ENTF-Taste oder über Kontextmenü (ab Programmversion 1.2.0.21)\\ **CharacteristicListClickOrderTool** "​Manuell nummerieren"​ (ab Programmversion 1.5.3.0)\\ **CharacteristicListNumberClockwiseTool** "​Im Uhrzeigersinn nummerieren"​ (ab Programmversion 1.5.3.0)\\ **CharacteristicListNumberReadDirectionTool** "​In Leserichtung nummerieren"​ (ab Programmversion 1.5.3.0)\\ **CharacteristicListNumberBySortnumberTool** "​Nach Listenposition nummerieren"​ (ab Programmversion 1.5.3.0)\\ **CharacteristicListEditStartnumber** "​Startnummer"​ (ab Programmversion 1.5.3.0)\\ **CharacteristicListSortTool** In Liste verschieben (ab Programmversion 1.5.3.0)\\ \\ __Fenster "​Merkmalübersicht"​__\\ **CharacteristicListToolBar** "​Werkzeugleiste“ ​ (verwendet ab Programmversion 1.2.0.31)\\ <​del>​**CharacterListToolBar**</​del>​ "​Werkzeugleiste“ (verwendet bis Programmversion 1.2.0.30)\\ \\ __Fenster "​Merkmaleigenschaften"​__\\ **CharacteristicDetailsView** "​Fenster Merkmaleigenschaften“ (verwendet ab Programmversion 1.2.0.31)\\ <​del>​**CharaterDetailsView**</​del>​ "​Fenster Merkmaleigenschaften“ (verwendet bis Programmversion 1.2.0.30)\\ \\ __Allgemein__\\ **UnsavedChangesDialog** Dialogfenster "​Ungespeicherte Änderungen",​ welches beim Schließen eines Projekts bzw. des Programms angezeigt wird, wenn es noch ungespeicherte Änderungen gibt; ein Speichern kann somit an dieser Stelle unterbunden werden (ab Programmversion 1.3.0.0) |+^ Affected​Element​Name | String | __"​Datei"​ (Menüleiste) und Werkzeugleiste__\\ **NewProject** "​Datei > Neues Projekt";​ "Neues Projekt“\\ **OpenProject** "​Datei > Projekt öffnen“; "​Projekt öffnen“\\ **SaveProject** "​Datei > Projekt speichern";​ "​Projekt speichern“\\ **SaveProjectAs** "​Datei > Projekt speichern unter“\\ **CloseProject** "​Datei > Projekt schließen“\\ **CloseApplication** "​Datei > Beenden“\\ \\ __Werkzeugleiste__\\ **StampTool** "​Stempel-Werkzeug“\\ **TagTool** "​Kennzeichnen-Werkzeug“\\ **GridTool** "​Feldeinteilung-definieren-Werkzeug“\\ \\ __Werkzeugleiste (nur Zeichnungsvergleich)__\\ **TransferTool** "​Merkmale übertragen“\\ \\ __"​Bearbeiten"​ (Menüleiste)__\\ **ProgramSettingGeneral** "​Einstellungen > Allgemein“\\ **ProgramSettingCharacteristics** \\ "​Einstellungen > Merkmale“\\ **ProgramSettingStamp** "​Einstellungen > Stempel“\\ **ProgramSettingImport** "​Einstellungen > Import“\\ **ProgramSettingExport** "​Einstellungen > Export“\\ **ProjectSettingsTolerance** "​Projekteinstellungen > Toleranztabellen“\\ **ProjectSettingsTags** "​Projekteinstellungen > Kennzeichnungen“\\ **ProjectSettingsCategories** "​Projekteinstellungen > Kategorien“\\ **ProjectSettingsTemplates** "​Projekteinstellungen > Stempelvorlagen“\\ **LicenseDialog** "​Hilfe > Lizenz anzeigen"​ (ab Programmversion 1.5.3.0)\\ **LicenseDialogAddLicense** "​Hilfe > Lizenz anzeigen > Lizenz hinzufügen"​ (ab Programmversion 1.5.3.0)\\ **LicenseDialogLicenseServerSetting** "​Hilfe > Lizenz anzeigen > Lizenzserver"​ (ab Programmversion 1.5.3.0)\\ **LicenseDialogRequestLicense** "​Hilfe > Lizenz anzeigen > Lizenz anfordern"​ (ab Programmversion 1.5.3.0)\\ \\ __Fenster "​Projektübersicht"​__\\ **ProjectEdit** "​Projekt > Projekt bearbeiten“\\ **ProjectAddDocument** "​Prüfplan > Zeichnungsblatt hinzufügen“\\ **ProjectAddInspPlan** "​Prüfplan hinzufügen“\\ **ProjectEditInspPlan** "​Prüfplan > Prüfplan bearbeiten“\\ **ProjectDeleteInspPlan** "​Prüfplan > Prüfplan löschen“\\ **<del>ProjectExportMenu</​del>​** "​Prüfplan > Exportieren als“ ​(verwendet bis Programmversion 1.3.7.0)\\ **ProjectExportJson** "​Prüfplan > Export ​als Json-Prüfplan“\\ **ProjectExportAscii** "​Prüfplan > Export ​als ASCII-Prüfplan (*.dfd)“\\ **ProjectExportDocument** "​Prüfplan > Export aller Zeichnungsgrafiken“\\ **ProjectExportStamps** "​Prüfplan > Export aller Stempelgrafiken“ (verwendet ab Programmversion 1.2.0.29)\\ <​del>​**ProcejectExportStamps**</​del>​ "​Prüfplan > Exportieren als > Stempelgrafiken“ (verwendet bis Programmversion 1.2.0.28)\\ **ProjectExportExcel** "​Prüfplan > Export ​als Excel-Prüfplan“\\ **ProjectExportCsv** "​Prüfplan > Export ​als CSV-Prüfplan“\\ **ProjectCloseDocument** "​Prüfplan > Zeichnungsblatt löschen“ (verwendet ab Programmversion 1.2.0.29)\\ <​del>​**ProjectCloseDokument**</​del>​ "​Prüfplan > Zeichnungsblatt löschen“ (verwendet bis Programmversion 1.2.0.28)\\ **DocumentVersionOpen** "​Prüfplan > Zeichnungsblatt > Zeichnungsblattversion ​öffnen“\\ **DocumentVersionRemove** "​Prüfplan > Zeichnungsblatt > Zeichnungsblatt entfernen“\\ **DocumentVersionExportPdf** "​Prüfplan > Zeichnungsblatt > Als PDF exportieren“\\ **DocumentVersionExportSvg** "​Prüfplan > Zeichnungsblatt > Als SVG exportieren“ (verfügbar ab Programmversion 1.2.0.31)\\ **DocumentVersionExportDwgDxf** "​Prüfplan > Zeichnungsblatt > Als DWG/DXF exportieren"​ (Standardwert ist "​Collapsed"​)\\ **CompareDocument** "​Prüfplan > Zeichnungsblatt > Zeichnungsblatt vergleichen“\\ \\ __Fenster "​Merkmalübersicht"​ und "​Zeichnungsfenster"​__\\ **CharacteristicContextMenu** "​Kontextmenü“\\ **DocumentSplitCadBlock** "​Kontextmenü > Zerlegen"​ (verfügbar ab Programmversion 1.2.0.31)\\ **DeleteStampKey** Stempel bzw. Merkmal löschen mit ENTF-Taste oder über Kontextmenü (ab Programmversion 1.2.0.21)\\ **CharacteristicListClickOrderTool** "​Manuell nummerieren"​ (ab Programmversion 1.5.3.0)\\ **CharacteristicListNumberClockwiseTool** "​Im Uhrzeigersinn nummerieren"​ (ab Programmversion 1.5.3.0)\\ **CharacteristicListNumberReadDirectionTool** "​In Leserichtung nummerieren"​ (ab Programmversion 1.5.3.0)\\ **CharacteristicListNumberBySortnumberTool** "Nach Listenposition nummerieren"​ (ab Programmversion 1.5.3.0)\\ **CharacteristicListEditStartnumber** "​Startnummer"​ (ab Programmversion 1.5.3.0)\\ **CharacteristicListSortTool** In Liste verschieben (ab Programmversion 1.5.3.0)\\ \\ __Fenster "​Merkmalübersicht"​__\\ **CharacteristicListToolBar** "​Werkzeugleiste“ ​ (verwendet ab Programmversion 1.2.0.31)\\ <​del>​**CharacterListToolBar**</​del>​ "​Werkzeugleiste“ (verwendet bis Programmversion 1.2.0.30)\\ \\ __Fenster "​Merkmaleigenschaften"​__\\ **CharacteristicDetailsView** "​Fenster Merkmaleigenschaften“ (verwendet ab Programmversion 1.2.0.31)\\ <​del>​**CharaterDetailsView**</​del>​ "​Fenster Merkmaleigenschaften“ (verwendet bis Programmversion 1.2.0.30)\\ \\ __Allgemein__\\ **UnsavedChangesDialog** Dialogfenster "​Ungespeicherte Änderungen",​ welches beim Schließen eines Projekts bzw. des Programms angezeigt wird, wenn es noch ungespeicherte Änderungen gibt; ein Speichern kann somit an dieser Stelle unterbunden werden (ab Programmversion 1.3.0.0) |
  
 </​WRAP>​ </​WRAP>​
de/infra-convert/dev/uiaccess.1585654195.txt.gz · Zuletzt geändert: 2020/03/31 13:29 von me