Benutzer-Werkzeuge

Webseiten-Werkzeuge


de:infra-convert:dev:uiaccess
Administratorhandbuch infra CONVERT > Konfiguration und Import

Parameterdatei »UiAccess«


Verfügbar ab Programmversion 1.1.5

In der Parameterdatei »UiAccess.json« ist festgelegt, welche Steuerelemente in der Benutzeroberfläche eingeblendet, ausgeblendet oder gesperrt sind.

Die Parameterdatei »UiAccess« wird bei der Installation an dieser Stelle gespeichert:

%ProgramData%/ELIAS GmbH/infra-convert/JsonData/UiAccess.json

Soll beim Programmstart eine andere Parameterdatei geladen werden, kann dies in der Startparameterdatei (siehe Konfiguration und Import > Parameterdatei zum Ein-/Ausblenden/Sperren von Steuerelementen) vorgegeben werden.


Inhalt

 • Administratorwerkzeuge
 • Elementname
 • Status


Administratorwerkzeuge

Datei mit Standardwerten exportieren

Eine vollständige »UiAccess.json« mit Standardeinstellungen können Sie im Administratormodus aus der Benutzeroberfläche von infra CONVERT heraus exportieren. (Verfügbar ab Programmversion 2.2.3)
Siehe Benutzerhandbuch > Einstellungen > Einstellungen > Administration > Gruppe »Konfigurationsdateien exportieren«

UiAccess-Parameter in der Benutzeroberfläche anpassen und exportieren

UiAccess-Parameter können Sie im Administratormodus direkt beeinflussen und das Ergebnis speichern. Starten Sie dafür infra CONVERT im Administratormodus und klicken unter Hilfe in der Menüleiste auf UIAccess bearbeiten (Admin). Im sich öffnenden Dialog können Sie alle verfügbaren UiAccess-Parameter durchsuchen und den Status ändern. Klicken Sie auf OK oder Übernehmen, um das Ergebnis für den aktuellen Programmaufruf zu setzen. Klicken Sie auf Speichern, um das Ergebnis für alle Benutzer zu speichern. Die UiAccess.json wird dafür in das ProgramData-Verzeichnis geschrieben. (Verfügbar ab Programmversion 2.5.0)


Elementname

Bezeichner des Steuerelements, das beeinflusst werden soll.

"AffectedElementName": "NewProject",
Parameter Typ Wert/Inhalt
Affected​Element​Name String Datei (Menüleiste) und Werkzeugleiste
NewProject Datei > Neues Projekt; Neues Projekt
OpenProject Datei > Projekt öffnen; Projekt öffnen
SaveProject Datei > Projekt speichern; Projekt speichern
SaveProjectAs Datei > Projekt speichern unter
CloseProject Datei > Projekt schließen
CloseApplication Datei > Beenden

Werkzeugleiste
StampTool Stempel-Werkzeug
TagTool Kennzeichnen-Werkzeug
GridTool Feldeinteilung-definieren-Werkzeug
EditLayersTool Layer ein-/ausblenden + Layer bearbeiten (ab Programmversion 2.8.0)
HideStampedCharacteristicsTool Gestempelte Zeichnungselemente ausblenden (ab Programmversion 2.5.0)
EditFiltersTool Merkmale filtern + Merkmalfilter bearbeiten (ab Programmversion 2.8.0)

Werkzeugleiste (nur Zeichnungsvergleich)
TransferTool Merkmale übertragen

Bearbeiten (Menüleiste)
ProgramSettingGeneral Einstellungen > Allgemein
ProgramSettingCharacteristics
Einstellungen > Merkmale
ProgramSettingStamp Einstellungen > Stempel
ProgramSettingImport Einstellungen > Import
ProgramSettingExport Einstellungen > Export
ProjectSettingsTolerance Projekteinstellungen > Toleranztabellen
ProjectSettingsTags Projekteinstellungen > Kennzeichnungen
ProjectSettingsCategories Projekteinstellungen > Kategorien
ProjectSettingsTemplates Projekteinstellungen > Stempelvorlagen
LicenseDialog Hilfe > Lizenz anzeigen (ab Programmversion 1.5.3.0)
LicenseDialogAddLicense Hilfe > Lizenz anzeigen > Lizenz hinzufügen (ab Programmversion 1.5.3.0)
LicenseDialogLicenseServerSetting Hilfe > Lizenz anzeigen > Lizenzserver (ab Programmversion 1.5.3.0)
LicenseDialogRequestLicense Hilfe > Lizenz anzeigen > Lizenz anfordern (ab Programmversion 1.5.3.0)

Fenster »Projektübersicht«
ProjectEdit Projekt > Projekt bearbeiten
ProjectAddDocument Prüfplan > Zeichnungsblatt hinzufügen
ProjectAddInspPlan Prüfplan hinzufügen
ProjectEditInspPlan Prüfplan > Prüfplan bearbeiten
ProjectDeleteInspPlan Prüfplan > Prüfplan löschen
ProjectExportMenu Prüfplan > Exportieren als (verwendet bis Programmversion 1.3.7.0)
ProjectExportJson Prüfplan > Export als Json-Prüfplan
ProjectExportAscii Prüfplan > Export als ASCII-Prüfplan (*.dfd)
ProjectExportDocument Prüfplan > Export aller Zeichnungsgrafiken
ProjectExportStamps Prüfplan > Export aller Stempelgrafiken (verwendet ab Programmversion 1.2.0.29)
ProcejectExportStamps Prüfplan > Exportieren als > Stempelgrafiken (verwendet bis Programmversion 1.2.0.28)
ProjectExportExcel Prüfplan > Export als Excel-Prüfplan
ProjectExportCsv Prüfplan > Export als CSV-Prüfplan
ProjectCloseDocument Prüfplan > Zeichnungsblatt löschen (verwendet ab Programmversion 1.2.0.29)
ProjectCloseDokument Prüfplan > Zeichnungsblatt löschen (verwendet bis Programmversion 1.2.0.28)
DocumentVersionOpen Prüfplan > Zeichnungsblatt > Zeichnungsblattversion öffnen
DocumentVersionRemove Prüfplan > Zeichnungsblatt > Zeichnungsblatt entfernen
DocumentVersionExportPdf Prüfplan > Zeichnungsblatt > Als PDF exportieren
DocumentVersionExportSvg Prüfplan > Zeichnungsblatt > Als SVG exportieren (verfügbar ab Programmversion 1.2.0.31)
DocumentVersionExportDwgDxf Prüfplan > Zeichnungsblatt > Als DWG/DXF exportieren (Standardwert ist »Collapsed«)
CompareDocument Prüfplan > Zeichnungsblatt > Zeichnungsblatt vergleichen

Fenster »Merkmalübersicht« und Zeichnungsfenster
CharacteristicContextMenu Kontextmenü
DocumentSplitCadBlock Kontextmenü > Zerlegen (verfügbar ab Programmversion 1.2.0.31)
DeleteStampKey Stempel bzw. Merkmal löschen mit ENTF-Taste oder über Kontextmenü (ab Programmversion 1.2.0.21)
CharacteristicListClickOrderTool Manuell nummerieren (ab Programmversion 1.5.3.0)
CharacteristicListNumberClockwiseTool Im Uhrzeigersinn nummerieren (ab Programmversion 1.5.3.0)
CharacteristicListNumberReadDirectionTool In Leserichtung nummerieren (ab Programmversion 1.5.3.0)
CharacteristicListNumberBySortnumberTool Nach Listenposition nummerieren (ab Programmversion 1.5.3.0)
CharacteristicListEditStartnumber Startnummer (ab Programmversion 1.5.3.0)
CharacteristicListSortTool In Liste verschieben (ab Programmversion 1.5.3.0)

Fenster »Merkmalübersicht«
CharacteristicListToolBar Werkzeugleiste (verwendet ab Programmversion 1.2.0.31)
CharacteristicListFilterToolBar Merkmale filtern + Merkmalfilter bearbeiten (verwendet von Programmversion 2.5.0 bis 2.7.13)
CharacterListToolBar Werkzeugleiste (verwendet bis Programmversion 1.2.0.30)

Fenster »Merkmaleigenschaften«
CharacteristicDetailsView Fenster »Merkmaleigenschaften« (verwendet ab Programmversion 1.2.0.31)
CharacteristicDetailsStampNumber Feld Stempelnummer (verwendet ab Programmversion 2.5.0)
CharacteristicDetailsStampPrefix Feld Präfix (ebenso angewendet auf den Stempeln-mit-Dialog; verwendet ab Programmversion 2.5.0)
CharacteristicDetailsStampPostfix Feld Suffix (ebenso angewendet auf den Stempeln-mit-Dialog; verwendet ab Programmversion 2.5.0)
CharaterDetailsView Fenster »Merkmaleigenschaften« (verwendet bis Programmversion 1.2.0.30)

Allgemein
UnsavedChangesDialog Dialogfenster »Ungespeicherte Änderungen«, welches beim Schließen eines Projekts bzw. des Programms angezeigt wird, wenn es noch ungespeicherte Änderungen gibt; ein Speichern kann somit an dieser Stelle unterbunden werden (ab Programmversion 1.3.0.0)


Status

Status der Zugänglichkeit des Steuerelements.

Anmerkung 1 Einstellungsdialoge können nur gesperrt werden (Status »Disabled«), auch wenn ihnen der Status »Hidden« oder »Collapsed« zugewiesen wird.

Anmerkung 2 Das Dialogfenster »Ungespeicherte Änderungen« (Parameter »UnsavedChangesDialog«) wird mit den Parametern »Disabled«, »Hidden« und »Collapsed« vollständig unterdrückt.

"AccessStatus": "Disabled"
Parameter Typ Wert/Inhalt
AccessStatus String Accessible Zugänglich und sichtbar (Standardwert)
Disabled Gesperrt
Hidden Unsichtbar, aber platzeinnehmend
Collapsed Unsichtbar und keinen Platz einnehmend

Zurückblättern
Konfiguration und Import > Parameterdatei »StampTemplates«

Weiterblättern
Konfiguration und Import > Toleranztabellen

de/infra-convert/dev/uiaccess.txt · Zuletzt geändert: 2021/10/28 17:16 von me