User Tools

Site Tools


en:infra-convert:dev:uiaccess
infra CONVERT Administrator’s guide > Configuration and Import

"UiAccess" Parameter file


Available from program version 1.1.5 and onwards

The “UiAccess.json” parameter file stipulates which control elements are visible, hidden or disabled in the user interface.

The “UiAccess” parameter file is saved at the following location during installation:

%ProgramData%/ELIAS GmbH/infra-convert/JsonData/UiAccess.json

If another parameter file is to be loaded when starting the program, this can be specified in the startup parameter file (see Configuration and Import > Parameter file for showing/hiding/locking control elements).


Content

 • Administrator tools
 • Element name
 • Status


Administrator tools

Export file with default values

You can export a complete “UiAccess.json” with default settings from the infra CONVERT user interface in administrator mode.
See User Manual > Settings > Setup > Administration > “Export configuration files” group. (Available from program version 2.2.3)

Customise and export UiAccess parameters in the user interface

You can affect UiAccess parameters directly in administrator mode and save the result. To do this, start infra CONVERT in administrator mode and click Edit UIAccess (Admin) under Help in the menu bar. In the dialogue that opens, you can browse all available UiAccess parameters and change the status. Click OK or Apply to set the result for the current programme call. Click Save to save the result for all users. The UiAccess.json is written to the ProgramData directory for this purpose. (Available from program version 2.5.0)


Element name

Identifier of control element to be affected.

"AffectedElementName": "NewProject",
Parameter Type Value/Content
Affected​Element​Name String “File” (menu bar) and toolbar
NewProject”File > New project”; “New project”
OpenProject ”File > Open project”; “Open project”
SaveProject ”File > Save project”; “Save project”
SaveProjectAs ”File > Save project as“
CloseProject ”File > Close project”
CloseApplication ”File > Close”

Toolbar
StampTool ”Stamp tool”
TagTool ”Tag tool”
EditLayersTool Show/hide layers + Edit layers (from programme version 2.8.0)
GridTool ”Tool for defining division of field”
EditFiltersTool Filter characteristics + Edit characteristic filter (ab Programmversion 2.8.0)
HideStampedCharacteristicsTool “Hide stamped drawing elements”

Toolbar (Drawing comparison only)
TransferTool ”Transfer characteristics”

“Edit” (menu bar)
ProgramSettingGeneral ”Settings > General”
ProgramSettingCharacteristics
“Settings > Characteristics”
ProgramSettingStamp ”Settings > Stamp”
ProgramSettingImport ”Settings > Import”
ProgramSettingExport “Settings > Export“
ProjectSettingsTolerance ”Project settings > Tolerance tables”
ProjectSettingsTags ”Project settings > Tags“
ProjectSettingsCategories ”Project settings > Categories”
ProjectSettingsTemplates ”Project settings > Stamp templates”
LicenseDialog ”Help > Show License“ (from program version 1.5.3.0)
LicenseDialogAddLicense ”Help > Show License > Load license“ (from program version 1.5.3.0)
LicenseDialogLicenseServerSetting ”Help > Show License > License server (from program version 1.5.3.0)
LicenseDialogRequestLicense “Help > Show License > Request license” (from program version 1.5.3.0)

“Project overview” window
ProjectEdit ”Project > Edit project”
ProjectAddDocument ”Quality control plan > Add drawings sheet
”ProjectAddInspPlan ”Add quality control plan”
ProjectEditInspPlan ”Quality control plan > Edit quality control plan”
ProjectDeleteInspPlan ”Quality control plan > Delete quality control plan”
ProjectExportMenu ”Quality control plan > Export as” (used up to program version 1.3.7.0)
ProjectExportJson ”Quality control plan > Export as Json Quality control plan”
ProjectExportAscii ”Quality control plan > Export as ASCII Quality control plan”
ProjectExportDocument ”Quality control plan > Export all Drawing graphics”
ProjectExportStamps ”Quality control plan > Export all Stamp graphics” (available from program version 1.2.0.29 upwards)
ProcejectExportStamps ”Quality control plan > Export as > Stamp graphics” (used up to and including program version 1.2.0.28)
ProjectExportExcel ”Quality control plan > Export as Excel Quality control plan”
ProjectExportCsv ”Quality control plan > Export as CSV Quality control plan”
ProjectCloseDocument ”Quality control plan > Delete drawings sheet” (available from program version 1.2.0.29 upwards)
ProjectCloseDokument ”Quality control plan > Delete drawings sheet” (used up to and including program version 1.2.0.28)
DocumentVersionOpen ”Quality control plan > Drawings sheet > Open drawings sheet version”
DocumentVersionRemove ”Quality control plan > Drawings sheet > Delete drawings sheet”
DocumentVersionExportPdf ”Quality control plan > Drawings sheet > Export as PDF”
DocumentVersionExportSvg ”Quality control plan > Drawings sheet > Export as SVG” (available from program version 1.2.0.31 upwards)
DocumentVersionExportDwgDxf “Quality control plan > Darwing sheet > Export as DWG/DXF”\\CompareDocument ”Quality control plan > Drawings sheet > Compare drawings sheet”

“Characteristics overview window” and “Drawings window”
CharacteristicContextMenu ”Context menu”
DocumentSplitCadBlock ”Context menu > Explode“ (available from program version 1.2.0.31 upwards)
DeleteStampKey Delete stamp or characteristic with DEL key or via Context menu (from program version 1.2.0.21 upwards)
CharacteristicListClickOrderTool Manually number (available from program version 1.5.3.0)
CharacteristicListNumberClockwiseTool Number clockwise (available from program version 1.5.3.0)
CharacteristicListNumberReadDirectionTool Number in reading direction (available from program version 1.5.3.0)
CharacteristicListNumberBySortnumberTool Renumber by list position (available from program version 1.5.3.0)
CharacteristicListEditStartnumber Start number (available from program version 1.5.3.0)
CharacteristicListSortTool Move in the list (available from program version 1.5.3.0)

“Characteristics overview” window
CharacteristicListToolBar ”Toolbar” (available from program version 1.2.0.31 upwards)
CharacteristicListFilterToolBar Filter characteristics (used from programme version 2.5.0)
CharacterListToolBar ”Toolbar” (used up to and including program version 1.2.0.30)

“Characteristics properties” window
CharacteristicDetailsView ”Characeteristics properties window” (available from program version 1.2.0.31 upwards)
CharacteristicDetailsStampNumber Stamp number field (used from programme version 2.5.0)
CharacteristicDetailsStampPrefix Prefix field (also applied to the stamp-with-dialogue; used as of programme version 2.5.0)
CharacteristicDetailsStampPostfix Suffix field (also applied to the stamp-with-dialogue; used as of programme version 2.5.0)
CharaterDetailsView ”Characeteristics properties window” (used up to and including program version 1.2.0.30)

General
UnsavedChangesDialog Dialog window “Unsaved changes”, which is displayed when closing a project or the program if there are still unsaved changes; in this way a saving can be prevented at this point (from program version 1.3.0.0).


Status

Accessibility status of control elements.

Note 1 Settings dialogues can only be locked (“Disabled” status), even if the status “Hidden” or “Collapsed” is assigned to them.

Note 2 The dialog window “Unsaved changes” (parameter “UnsavedChangesDialog”) is completely suppressed with the parameters “Disabled”, “Hidden” and “Collapsed”.

"AccessStatus": "Disabled"
Parameter Type Value/Content
AccessStatus String Accessible Accessible and visible (default value)
Disabled locked
Hidden Invisible, but occupying space
Collapsed Invisible and not occupying space

Scroll backwards
Configuration and Import > "StampTemplates” parameter file

Scroll forwards
Configuration and Import > Tolerance tables

en/infra-convert/dev/uiaccess.txt · Last modified: 2021/10/22 16:19 by me