User Tools

Site Tools


en:infra-convert:user:cadexp:nx_6
User manual infra CONVERT > Export drawing from the CAD system > Siemens PLM

NX 6


This manual describes how to export drawing files in DWG, DXF and IGES formats (→Drawing data format) from the NX 6 CAD system. The recommended settings ensure that the drawing file can be read by infra CONVERT in the best possible way.

The following NX licenses are required:

  • Dxfdwg
  • ug_to_dxf
  • 3d_to_2d_flattener

Due to some errors with the DXF/DWG export (as of March 2010), we recommend using the IGES format. Some dimensions are seemingly not output as a block in the DXF/DWG format, but rather as individual elements and texts. Therefore the information in infra - CONVERT may not be automatically transferred. This applies especially to radii and angular dimensions.

Content

 • DWG export
 • DXF export
 • IGES export


DWG export

Step Action/result
1 Customize drawing view Open the Default drawing view menu via Default settings > Drawing view. Deactivate the Display margins selection on the View tab.
2 Customize export settings Open the 2D exchange options menu via File > Export > 2D exchange. Select the following settings on the File, Data for export and Advanced tabs.

Note If you use the Pro version of infra CONVERT, you can export all sheets into one file (starting with program version 1.4.0.5). This reduces the number of files.
3 Export drawing Export the drawing in DWG format following the instructions for NX 6.


DXF export

Step Action/result
1 Customize drawing view Open the Default drawing view menu via Default settings > Drawing view. Deactivate the Display margins selection on the View tab.
2 Customize export settings Open the 2D exchange options menu via File > Export > 2D exchange. Select the following settings on the File, Data for export and Advanced tabs.

Note If you use the Pro version of infra CONVERT, you can export all sheets into one file (starting with program version 1.4.0.5). This reduces the number of files.
3 Export drawing Export the drawing in DXF format following the instructions for NX 6.


IGES export

Step Action/result
1 Customize drawing view Open the Default drawing view menu via Default settings > Drawing view. Deactivate the Display margins selection on the View tab.
2 Customize export settings Open the 2D exchange options menu via File > Export > 2D exchange. Select the following settings on the File, Data for export and Advanced tabs.
3 Export drawing Export the drawing in IGES format following the instructions for NX 6.

Go to previous page
Export drawing from the CAD system > PTC > Creo Elements/Direct Modeling 20.0

Go to next page
Export drawing from the CAD system > Siemens PLM > NX 10

en/infra-convert/user/cadexp/nx_6.txt · Last modified: 2019/11/06 10:35 by me