User Tools

Site Tools


en:infra-convert:user:cadexp:nx_10
User manual infra CONVERT > Export drawing from the CAD system > Siemens PLM

NX (from version 10)


Described are export settings for the CAD system “Siemens NX” from version 10. With the recommended settings you ensure that the drawing file can be read by infra CONVERT in the best possible way.

Basically, it should be noted that fonts must be installed on the respective PC when processing drawing files in an exchange format, such as DXF, DWG or PDF.
SeeDealing with missing fonts

If an export result is not satisfactory despite the configuration recommendations, we will be happy to support you directly.


Content

 • DXF/DWG export
 • IGES export
 • PDF export


DXF/DWG export

Manufacturer's documentation for DXF/DWG export (from version 12): Siemens documentation: DXF/DWG export.

Recommended configurations:

Drafting preferences File > Drafting preferences > View > Workflow > Border 
└ Display: Off

Version 10:    Version 12:
  
Load Settings File > Export > AutoCAD DXF/DWG… > Load Settings 
└ Load From: Settings file (*.def)*

* The configuration file should contain the following value assignment: 
└ UGI_GDT_EXPORT_AS_BLOCK = NO
Input and Output File > Export > AutoCAD DXF/DWG… > Input and Output 
└ Export To: DXF or DWG
└ Export As: 2D

Version 10:       Version 12:       Version 1899:
    
Data to Export File > Export > AutoCAD DXF/DWG… > Data to Export 
└ Model Data/Drawing: Drawing

Version 10:       Version 12:       Version 1899:
    
Options File > Export > AutoCAD DXF/DWG… > Options 
└ DXF/DWG Revision: 2018-2020
└ Export Spline As: Spline
└ Remove Overlapping Entities: No
└ Scale Option: No Scale
└ Scale Value: 1.0000

Version 10:       Version 12:       Version 1899:
    
Fonts File > Export > AutoCAD DXF/DWG… > Fonts 
└ Text Width: Use NX Aspect Ratio
└ latin_extended: isocp.shx

Version 10:       Version 12:       Version 1899:
    


IGES export

Manufacturer's documentation for IGES export (from version 12): Siemens documentation: IGES translator.

Recommended configurations:

Drafting Preferences File > Drafting Preferences > View > Workflow > Border 
└ Display: Off

Version 10:    Version 12:
  
Files File > Export > Export to IGES Options > Files 
└ Export from: Drawings
└ Export to: IGES file

Version 10:
Data for Export File > Export > Export to IGES Options > Data for Export 
└ Export: Selected Drawings

Version 10:
Advanced File > Export > Export to IGES Options > Advanced 
└ NX 3D to 2D options > Enclose facet body: Yes
└ NX 3D to 2D options > Convert GDT as a group: No

Version 10:


PDF export

Manufacturer's documentation for PDF export (from Version 12): Dialog window "Export PDF".

Recommended configurations:

Export PDF File > Export > PDF… 
└ Source: Select sheets
└ Colors: Black on white
└ Size: Original size
└ Output text: Text
└ Export grid images to drawing: Yes
└ Image resolution: Medium to Hight

Version 10:

Go to previous page
Export drawing from the CAD system > Siemens PLM > NX 6

Go to next page
Export drawing from the CAD system > Siemens PLM > Solid Edge ST2

en/infra-convert/user/cadexp/nx_10.txt · Last modified: 2021/06/22 16:08 by me